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Chapter 1: Introduction

1.1What is gtkpod?
gtkpod is a platform independent GUI for Apple's iPod using GTK2. It allows you to
upload songs and playlists to your iPod. It supports ID3 tag editing, multiple charsets for
ID3 tags, detects duplicate songs, allows offline modification of the database with later
synchronization, and more. (Taken from http://gtkpod.sourceforge.net).

1.2Who is this manual for?

This manual is for anyone with an interest in using the gtkpod software. Generally this set
of people consists of Linux users who own an iPod, but it is not at all limited to that set of
people. If you do not have basic experience with the Linux operating system, then you
may find this manual a little difficult to understand. With a little determination anyone
should find this manual very useful in gaining an understanding of gtkpod; from
installation to advanced use.

1.3How to use this manual
This manual can be considered anything from a simple gtkpod tutorial to an advanced
reference of gtkpod. It covers all bases in the usage of gtkpod. This manual is organized
in an advancing design, starting with the most basic aspects of gtkpod usage including
installation and starting the program, and concludes with explanations of the most
advanced features of gtkpod such as volume normalization configuration.



Chapter 2: Installing gtkpod

2.1System Requirements
Before you can install gtkpod on your system, your system must meet some very basic
requirements. Most of these requirements are standard at the time this manual was

written.

An x86, SPARC, 1A64, or AMD64 system

A GNU distribution of Linux running kernel 2.4.x or 2.6.x compiled with
support for USB or Firewire device file systems, and support for either a VFAT
or HFS file system

Note:

Most any Linux distribution will satisfy the previous
requirement, but some common ones are Redhat,
Mandrake, Linspire (Lindows), Debian, and Gentoo.

You must be running the X windowing system

Note:
If you have a graphical user interface at all, then there is a 99% chance that
you are running the X windowing system.

Your system must have the GTK?2 libraries installed

Note:
This library is usually required by other programs you might run, and is
probably already installed on your system.

5 Megabytes of available hard disk space

At least 16 Megabytes of system memory

A working internet connection

An iPod of any generation, including the most recent 4™ Generation iPods.

2.2Getting The Files You Need

The latest version of gtkpod can be downloaded from:

http://sourceforge.net/project/showfiles.php?group id=67873

To download gtkpod from the command line, open the link in your favorite browser.

Once there click on gtkpod-x.x-x.tar.gz (where the x's denote a version number). You
should now be taken to a list of mirror servers from which you can download gtkpod.
Copy the link location of the archive and mirror you'd like, and at your command line

type:



wget http://prdownloads.sourceforge.net/gtkpod/gtkpod-x.xx-
X.tar.gz?use_mirror=xxx

Where x.xx-X is the version of the archive you chose, and xxx is the mirror you chose.
Alternatively you can just click on the link to a mirrored copy of your desired archive in
your browser and your browser should hand the file download accordingly. You should
now have an archive of the latest version of gtkpod in your current working directory, or a
destination that you chose.

2.3Extracting Files

Extracting your files is simple. Since you will probably be performing the rest of the
installation from a command line, it is probably a good idea to open one now. From the
command line browse to the location at which you put your gtkpod archive.

cd /path/to/directory/of/gtkpod/archive

Once there, simply type the following command, and you are well on your way to
installing gtkpod:

tar -xzvf gtkpod-x.x-x.tar.gz

This command extracts a gzipped tar file. A directory named gtkpod-x.x-x will be created
containing the gtkpod source code. Once again here the x's represent a variable version
number.

2.4Configuring And Compiling

Before gtkpod can be installed into a usable form, it must first be configured and
compiled. Luckily for us, both of these tasks are pretty well automated in GNU Linux. To
perform both of these tasks, simply browse to your newly created gtkpod directory that
contains the gtkpod files for the version you're installing, and type:

J/configure
make

Note:
It is normal for a lot of text to be printed at your command line.

Note:

Each command you issue will be finished once new text does not appear at
your command line for a long period of time. This period of time will
lengthen for slower processors, and inversely shorten for faster processors.
Each command you issue is complete once you are returned to your
command prompt.

If the previous commands ended in error (there was a very long error message or
sequence of error messages printed to your screen, and compilation exited abnormally),



then one of two things has happened. You have either not met the system requirements in
some way, or you have found an error in the gtkpod installation. Usually the problem is
not the latter of these two. If you did not get a compilation error (you got an error when
running ./configure), then try to decipher the error message and see what your system is
missing such that the gtkpod install cannot complete. If you got a compilation error when
running make, you've most likely found a bug in gtkpod, and we would like for you to tell
us about it! Please visit http://gtkpod.sourceforge.net for information on doing so.

2.5Installing The gtkpod Binaries

In Section 2.4 you generated some binary executables by compiling the gtkpod source
code. Now in order to make using gtkpod easier, we will install those binaries into
appropriate places on your system. There is an easy way of doing this, but it requires that
you be logged in as a superuser in order to protect the security of your system. A quick
way to get access to a superuser terminal from your command line is the su command. To
install the gtkpod binaries, run the following commands:

su
<enter in your superuser password>
make install

This will install the gtkpod binaries to standard places on your system and make them
readily available for use.

2.6Connecting An iPod To Your System

In order for gtkpod to work, your system must be able to “talk to” your iPod. This is done
by loading the appropriate kernel module. The appropriate kernel module is a program
that runs in the background of your system listening for incoming Firewire or USB
connections. Once it receives a connection from a device, and finds out that that device is
a storage device, it creates a usable “link™ to the device if your kernel also can determine
what file system is used by that device (either HFS or VFAT, which your kernel should
support for use with your iPod). If you're unsure whether or not your kernel is compiled
with the appropriate modules, consult your Linux distribution's user manual and forums.

Supposing that your kernel is setup correctly, the only thing left to do is to plug an iPod
into your system, and mount the iPod to a location on your file system. We will assume
that your kernel has assigned your iPod to the device link /dev/sda, and thusly your kernel
has assigned your iPod's file system partitions to the device links /dev/sdal and /dev/sda2.
Do not ever touch the /dev/sdal device link, as that is where your iPod stores it's own
low-level software. We are concerned with your /dev/sda2 device link, which is where
your iPod stores music and other miscellaneous files.

gtkpod would like to automatically mount your iPod for you every time you start gtkpod.
In order for this to work you must provide gtkpod with access to do so. This involves
adding a line to your /etc/fstab file, and creating a directory for your iPod to be mounted
at. To do this you must be logged in as superuser, but for simplicity we will utilize the su
command. We'll create the iPod's mount directory using the mkdir command. To edit the



file, open it in your favorite text editor (here we use the popular command line editor
pico, but nano is used on some systems):

su

<enter in your superuser password>
mkdir /mnt/ipod

pico /etc/fstab

Once open, you can now start making changes to your /etc/fstab file. Move your cursor to
the end of the file, and type the following line:

/dev/sda2 /mnt/ipod  vfat noauto,rw,user 00

Replace sda2 with the appropriate device link to the “music” partition of your iPod. If
your iPod has not been formatted with a VFAT file system (this is done using the iTunes
software in Microsoft Windows), then replace “vfat” in the previous line with “hfs”.

Once you've finished making changes to your /etc/fstab file, save your changes (in pico or
nano this is done by hitting CTRL+0), and exit the program (this is done by pressing
CTRL+X in pico or nano).

WARNING:

Do NOT disconnect your iPod from your system without first ejecting it
from your device links. If you do so, the file system on your iPod can
easily be corrupted. The commands to eject your iPod are:

su
<enter in your superuser password>
eject /dev/sda2

Supposing that your kernel assigned your iPod to the device link of
/dev/sda.



Chapter 3: Starting gtkpod

3.1From The Command Line
Starting gtkpod from the command line is as simple as going to a terminal and typing:

gtkpod &

3.2From KDE

To start gtkpod from KDE, you must either add a desktop shortcut to gtkpod, or
alternatively add a Kmenu item for gtkpod.

To add a desktop shortcut, right click on your wallpaper and select:
Create New | File | Link To Application

In the General tab, enter in a label for the new link. After that select the Application tab.
Once there enter in a Command of “gtkpod”. Optionally an icon for this new link can be
selected by clicking on the gear icon in the General tab.

To add a Kmenu item for gtkpod, right click on the K button on your task bar, and select
Menu Editor. Once there select File | New Item. In the new dialog box, type “gtkpod”, or
something appropriate to label the new menu item, and click OK. You'll now notice a
new entry with a name you just specified. Click on that entry, and in the right pane of the
window, in the Command text box enter “gtkpod”. Optionally you can select an icon for
this new menu item by clicking on the blue and white paper icon in the upper right of the
right pane. Once you've finished making your changes, select File | Save to save your
changes.

To start gtkpod from KDE, select the desktop shortcut or menu item that you just created.



Chapter 4: The gtkpod Graphical User Interface
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4.1Application Menu
1. The File Menu

This menu allows access to the basic tools of gtkpod, including the abilities to
read an iTunes database from the iPod, add files to the currently selected playlist,
add directories of files to the currently selected playlist, add a playlist to the
currently selected playlist, creating a new playlist, and uploading the current
organization to the iPod. Note that the majority of these features can be accessed
from the Main Toolbar.

This menu also allows some advanced file management such as syncing from the
1Pod to the local file system, or visa versa.

If your iPod has somehow lost its directory structure, you can create new iPod
directories using this menu, as well as check that existing ones are valid.

Finally this menu allows you to take your iPod offline, and also to quit the
program.



2. The Edit Menu

This menu gives access to advanced playlist creation and management features,
such as creating a playlist for each selected album, or randomizing the current
playlist. The Edit Menu also allows you to delete playlists or selected tracks
from your iPod.

You can also access all sorting methods from the Edit Menu, allowing you to
quickly organize your music into an order that you prefer.

gtkpod configuration is accessed from this menu, or alternatively by pressing
CTRL+P.

3. The View Menu

From this menu, you can enable or disable the Main Toolbar, tooltips, and
Information Window. A check box next to a menu item means that that item has
been enabled.

If you feel that you need more or sets of tabs in the Group Panes, you can add or
remove entire sets of tabs using the menu options More Tabs or Less Tabs.

The Arrange Sort Tabs feature evenly distributes the groups of tabs over the
space allotted to the Group Panes, and sorts the list items in each group of tabs.

4. The Tools Menu

gtkpod seamlessly integrates with your favorite music player in order to allow
you to play music as you manage it with gtkpod. From the Tools Menu you can
play or enqueue entire playlists or currently selected tracks.

The Tools Menu also allows you to normalize the volume on any combination of
tracks.

If you wanted to synchronize your contacts or calendar, the Tools Menu is what
you would use to do so.

Many features in the Tools Menu depend upon your currently chosen gtkpod
configuration which is set by the Edit Preferences option of the Edit Menu.

5. The Help Menu

From the Help Menu you can access information about gtkpod, and eventually
you will be able to access this manual from the Help Menu.

4.2Main Toolbar

The Main Toolbar allows for quick access to the main features of gtkpod.

From this toolbar you can quickly read an iTunes database from your iPod, or just
as easily sync your current playlist configuration to your iPod.

This toolbar is also a quick and easy way to add files, directories, or playlists to the
playlist you're currently editing, or alternatively create a new playlist.

4.3Playlists Pane

All of the playlists that are read from your iPod are initially placed here. Playlists that you
add will also go here, ultimately to be synced onto your iPod. Selecting a playlist from
this pane modifies the information displayed in the Group Panes and Track Pane, as the
Playlist Pane governs them both. Playlists can be quickly managed by right clicking on a
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playlist.

4.4Group Panes

The Group Panes each maintain a group of tabs. Each tab shows abstracted information
about the songs in the currently selected playlist. Selecting a different tab shows the
appropriately labeled information in that pane. Selecting a single list item in a Group
Pane will change what is displayed in the Track Pane. Depending upon which tab and list
item are currently selected, the according tracks will be displayed in the Track Pane. For
instance if you selected the Artist tab, and from the list under the Artist tab you selected
the artist My Band, all tracks my My Band would be displayed that have been added to
the currently selected playlist. Group Panes can be created or removed using the View
Menu explained in Section 4.1. Using multiple Group Panes at once allows you to more
filter out the tracks displayed in the Track Pane. Right clicking on a list item in a Group
Pane will allow you fast access to actions that can be performed on the selected item.

4.5Track Pane

The Track Pane displays tracks found in the currently selected playlist that match the
requirements set forth by the selections made to a Group Pane. Right clicking on a track
in the Track Pane will allow you fast access to many features to perform on the selected
track.

4.6Information Window

Total Selec_ted Displayed | Selected
Playlist | Tracks Tracks

|Murnber of tracks 787 53 53 ]
Play tirme 58:16:22 3:42:47| 3:42:47| 0:00:00
Fle size 4.23GB| 319MB| 319 MB| 0B
| Number of playlists | 1
Deleted tracks | 3
File size (deleted) _15.0MB
Mon-transfered tracks 0
Fle size (non-transfered)| 0B ¥ Close
|Free space on iPod 15.7 GB

The Information Window displays a multitude of information about your current gtkpod
session. The table layout of the window is for the most part self-explanatory.
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Chapter 5: Configuring gtkpod

Preferences

InputfQutput | Display I Edit |Ioo|5 I
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or syncing tracks

¥ Add directories recursively

[ Don't allow file duplication =
[+ Display info about detected duplicates

When adding dirs/files, update information of
existing tracks with identical filenames

[« Displayinfo about updated tracks

[« Display info about non-updated tracks
When syncing directories

[+ Confirm list of directories

[« Delete tracks that hawe been remowved

[ Confirm before remowving tracks

X cancel o Apply | Hox |

Note:
The Preferences dialog can be accessed from the Edit Menu, or by
pressing CTRLAP.

Note:
To apply your configuration changes, simply click Apply, and then click
OK to close the dialog.

5.1Input/Output

The Input/Output tab contains all configurations regarding data input and output to your
1Pod. It is mainly divided into two sections: Import Configuration and
Adding/Updating/Syncing Configuration. The properties of both are listed and labeled,
and should be self-explanatory.

5.2Display

From the Display tab you can customize the way gtkpod displays information to you.
Here you can select what data is displayed in the Track Pane, as well as customize
gtkpod's toolbars. A nice feature is at the bottom of this list; blocking the display when
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changing a playlist or tab entry will greatly increase the speed at which gtkpod processes
requests.

5.3Edit

The Edit tab allows you to turn gtkpod into an entire music management tool. From here
you can have gtkpod write your track modifications to the local hard disk. You can also
enable Multi-Edit to edit multiple title tags at once. You can limit the number of tracks to
be put in an automatically generated playlist. If you would like to modify when delete
confirmation dialogs pop up, then the Edit tab allows for these changes.

5.4Tools

In the Tools tab you can modify what music player gtkpod uses to play tracks that you tell
it to, and also modify the command used for volume normalization, contacts, and
calendar synchronization. Volume normalization requires that you have the mp3gain
program installed upon your system. To setup volume normalization enter in the path to
that program in the Volume Normalization section.

gtkpod is distributed with multiple scripts to synchronize contacts and your iPod's
calendar. These scripts are found in /usr/local/share/gtkpod/scripts/. If one of these scripts
meets your specific needs, enter in the command to use the script into the corresponding
text box in the Contacts/Calendar section.
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Troubleshooting

I could not get gtkpod to compile, the configure script or makefile gave me an error,
what do I do?

Read the error to see if you can determine the problem. If in the configure script you were
notified that you did not have one of the required programs or libraries, you should look
into getting the program or library specified. If you got a compilation error, you have
probably found a bug in gtkpod or the gtkpod installation, and we would like to know
about it. Please visit http://gtkpod.sourceforge.net/ for contact details.

When I start gtkpod and try to read the iTunes database off of my iPod, gtkpod says
it was unable to do so, what's wrong?

Make sure that you setup a mount point for your iPod, and listed that mount point in your
fstab file, giving users permission to mount and unmount it at will. Your fstab file may
need to be changed over time as you connect and disconnect your iPod from your system,
as your kernel could potentially assign the iPod to a different device link, thus making the
/mnt/ipod line of your fstab file invalid. Also check to make sure the file system on your
1Pod is entact. Disconnecting an iPod without ejecting it first can corrupt the file system
on your iPod.

gtkpod dies consistently when I perform a certain task, what should I do?
You've most likely discovered a bug in gtkpod. Please visit http://gtkpod.sourceforge.net/
to get information on submitting a bug.

I would like to contribute to the gtkpod project, where do I start?

If there is a feature you would like implemented or a bug you would like fixed and you
know how to fix it, please create a patch of your working gtkpod source, and send it to

the destination specified at http://gtkpod.sourceforge.net/ . Your patch will be reviewed
and implemented if found beneficial to the gtkpod project.
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Appendix A: Upgrading gtkpod

Upgrading gtkpod is as simple as going through the installation process again. The
gtkpod configuration is stored in your home directory, which is unaffected by an
installation. Performing another installation merely overwrites the program files on your
system, thusly updating gtkpod.

Appendix B: Legal Information

iTunes and iPod are trademarks of the Apple Corporation.

gtkpod and this document are not supported, written, or published by the Apple
Corporation.

gtkpod is free software; you can redistribute it and/or modify it under the terms of the
GNU General Public License as published by the Free Software Foundation; either
version 2 of the License, or (at your option) any later version.

gtkpod is distributed in the hope that it will be useful, but WITHOUT ANY
WARRANTY; without even the implied warranty of MERCHANTABILITY or
FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
for more details.

This document is released under the Creative Commons License, and those using this
document are bound to the conditions specified by that license. Information on this
license can be found at http://creativecommons.org/licenses/by-nc/1.0/.
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